Please post your question in the right forum. We will answer it as soon as possible.

Main Menu

Theme options not saving.... what to do?

Started by WISH MASTER, May 20, 2019, 02:55:17 AM

Previous topic - Next topic


I am using a theme from mythemeshop. Same theme I used in several others website. There everything is working just fine. Today I looked into one of my site and tried to change the logo image.

The problem is I can delete the image from theme options panel, but when I try to add new image and then press the save button, it doesn't work. The save button redirects me to 404 page. same thing works just fine on siteground.

The one I am facing problem is with Namecheap. Any Idea?
Do not PM me. Post in the thread to get quick reply.


It might be a theme specific issue or might be caused by some plugin. you have to check one by one.

01. Try deactivating all plugins then try saving theme options.

02. Try to use a default theme and try to save options, what happens?

03. Try clearing your browser cache and do the same again.

As you said this is from mythemeshop, you can also ask in their forum.

I have another suggestion for you, to check if your .htaccess is written properly or anything is blocked by .htaccess

Lastly, you can contact namecheap support if they have any mod_security triggered for your domain. I guess they can solve your problem as you said the same theme is working just fine on siteground.

Sometime hosting block some functions for security and shared users are not able to whitelist those.

In some cheap hosting the memory limit can also be a problem sometimes.

I think it's always trial and error to find what is causing the problem.
I do what I love, Money Comes on the Way.


I have to make it clear a bit. The "save" button takes me to a 404 page and the URL on the address bar is like this " https://my_site/wp-admin/options.php"

I guess it's the hosting. They are blocking something.
Do not PM me. Post in the thread to get quick reply.


So, I talked with namecheap live support and so sweet, the problem is solved. It was from their side that was triggered to block some mod_security. They whitelisted the actions for my cPanel and wallA... I can save theme options again.

My .htaccess and plugins are working just fine.
Do not PM me. Post in the thread to get quick reply.